Author Topic: Audio problem with Foscam 8918W or 8910W  (Read 11371 times)

philou

  • Newbie
  • *
  • Posts: 3
    • View Profile
Audio problem with Foscam 8918W or 8910W
« on: April 25, 2012, 10:16:05 AM »
The app works as it should, but eventually after a few minutes, a problem with the audio appears.
The level of noise seem to increase slowly but surely, as shown by the 'current' slider. Eventually it triggers the alarm levels even if the room has no noise.

Exiting the specific cam back to all the cams then going back fixes it temporarily. maybe the app should cycle by itself?

This makes it impossible to use the app for baby monitoring.

The cameras are connected through wifi.

On another note, a great feature to have would be monitoring of several audios at the same time, with multiple alarms.

Tks

Barry@EggmanTech

  • Administrator
  • Hero Member
  • *****
  • Posts: 761
    • View Profile
    • Eggman Technologies
Re: Audio problem with Foscam 8918W or 8910W
« Reply #1 on: April 26, 2012, 05:37:52 PM »
Yes, we are aware of this. We actually used to cycle the audio to prevent this but it caused the crackle and pop noises people were complaining about earlier. We now use the suggested algorithm but it exhibits volume issues. The only solution is for us to decode audio from the mpeg stream instead of the native one. This will take some time.

philou

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Audio problem with Foscam 8918W or 8910W
« Reply #2 on: April 27, 2012, 10:43:57 AM »
Ok thank you. You are obviously aware of the issue, which is the most important. As you know, more and more people want to use the app as baby monitoring. I would think it is a good selling point for you if you can make this work, and then put more emphasis on that in that app store.

Barry@EggmanTech

  • Administrator
  • Hero Member
  • *****
  • Posts: 761
    • View Profile
    • Eggman Technologies
Re: Audio problem with Foscam 8918W or 8910W
« Reply #3 on: April 27, 2012, 03:10:06 PM »
Yes, we are trying to let people know about baby monitoring capabilities. Sadly most consumers are buying Foscams for this and they are perhaps the least reliable for the task.

Stuartforrest

  • Guest
Re: Audio problem with Foscam 8918W or 8910W
« Reply #4 on: May 07, 2012, 06:57:28 PM »
I hope you will fix this soon. We have two cameras in our childs room and have been using your app for ages for this purpose. Sad it has gone wrong. We are still using it but I have to listen to her snoring all night until you fix it.

Barry@EggmanTech

  • Administrator
  • Hero Member
  • *****
  • Posts: 761
    • View Profile
    • Eggman Technologies
Re: Audio problem with Foscam 8918W or 8910W
« Reply #5 on: May 07, 2012, 07:13:32 PM »
We'll get it sorted out! Snoring is no fun :(

Stuartforrest

  • Guest
Re: Audio problem with Foscam 8918W or 8910W
« Reply #6 on: May 08, 2012, 05:40:01 PM »
Great thanks.

Stuartforrest

  • Guest
Re: Audio problem with Foscam 8918W or 8910W
« Reply #7 on: May 19, 2012, 05:32:31 PM »
I wondered if you going to fix this?  There has been another release but it still is a problem. If you are choosing not to fix it please say so and I will try to find another solution. This worked well for a long time until I think it was version 1.92 or perhaps 1.91.

Thanks.

Stuart Forrest.

Barry@EggmanTech

  • Administrator
  • Hero Member
  • *****
  • Posts: 761
    • View Profile
    • Eggman Technologies
Re: Audio problem with Foscam 8918W or 8910W
« Reply #8 on: May 19, 2012, 09:35:14 PM »
Yes we are trying to fix it (of course!). Version 1.94 is the one we are trying to resolve it in. The other releases are quick patches for other issues.

Stuartforrest

  • Guest
Re: Audio problem with Foscam 8918W or 8910W
« Reply #9 on: June 25, 2012, 06:07:45 PM »
Any chance you are going to fix this.  It's been ongoing for two months. It worked perfectly in version 1.92. Can't you just go back to what you had there? 

Barry@EggmanTech

  • Administrator
  • Hero Member
  • *****
  • Posts: 761
    • View Profile
    • Eggman Technologies
Re: Audio problem with Foscam 8918W or 8910W
« Reply #10 on: June 29, 2012, 10:25:37 PM »
Stuart,

I've been busy working on the next release for the past two months. If the Foscam driver change was the only change it would have taken days not months.
You'll soon see that I've been extremely busy :)

Sorry it's taking so long but I've got a lot of changes to test. The 2.0 release is going to be more stable than ever.

curtissh

  • Guest
Re: Audio problem with Foscam 8918W or 8910W
« Reply #11 on: June 30, 2012, 02:02:54 AM »
Can't wait for this update. This is the lone app with the squelch feature. If only it would work all night!  With that fixed, this will promptly climb to the top.

matt0062

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: Audio problem with Foscam 8918W or 8910W
« Reply #12 on: July 01, 2012, 01:43:09 PM »
I have haing this same problem even though I'm using a different camera.  It's still a Foscam (technically an Agasio - same company) - Model is A503W.  I noticed in the thread that you indicated that this issue could be due to the camera, or at least it is implied as much.  Would this mean that another camera manufacturer / model would not have this issue?  I don't really understand why that would be, but am interested in your thoughts.

Additionally, I am interested in when you think the issue would be resolved?

 Like the last user, I can deal with crackle / pop in the audio stream if it fixes the escalating volume problem.  I too am using this as a baby monitor, so audio volume is critical while audio quality is simply a nice feature. 

Thanks

Macnbaish

  • Newbie
  • *
  • Posts: 1
    • View Profile
Re: Audio problem with Foscam 8918W or 8910W
« Reply #13 on: July 01, 2012, 05:18:51 PM »
New Live Cams Pro user. We are expecting our first baby in November and like the other posters I decided to go with a webcam for baby monitoring. Mine is a Wansview, but it is exhibiting this same issue. I hope you'll have it fixed before November! I've also noticed that the app appears to freeze when left to run overnight with audio on. Not sure if that is related to this bug. The video stops updating, and tapping the screen does not activate the control overlay. If I hit the home button and then return to the app a black screen is displayed for a few seconds and then it crashes to the Home screen. If I disable audio the app runs all night just fine. Not sure if you were aware of this but wanted to bring it to your attention.

Barry@EggmanTech

  • Administrator
  • Hero Member
  • *****
  • Posts: 761
    • View Profile
    • Eggman Technologies
Re: Audio problem with Foscam 8918W or 8910W
« Reply #14 on: July 02, 2012, 04:00:55 PM »
The Wansview device is probably a clone of the Foscam and therefore sharing the same "driver" in our source code. We've been doing heavy testing on audio and stability for several months so we're definitely on it!

As for the crashes, we're doing what we can to eliminate these as we reproduce them. We did not encounter this during our testing but the scenario is probably timing or network-related. Our next release (v2.0) contains updates to resolve volume issues and has a new algorithm that may eliminate the crash you saw.